Install Elasticsearch on Linux or Mac OS X

Manual or Brew installation

You need JAVA, start by installing/updating Java. If you plan to do development with Elasticsearch, get the JDK, otherwise, the JRE will be sufficient. Official downloads page.